PDA

View Full Version : digital signature


hanss
9th November 2011, 16:50
Dear all,

I have a problem with my SAITEK Pro Flight Yoke: Under Root enumerator; Magic Bus; it says “The digital signature necessary for the drivers of this device cannot be checked. It is possible that after a recent hardware- or softwarechange a document has been installed which has incorrectly been signed or damaged, or damaging software of an unknown source has been installed.(Code 52)” I have translated this text from Dutch.

Could you help me please

Regards

hanss

UK Support 4
10th November 2011, 11:24
Hi, uninstall the software, do this first.
Then down load the cyborg software and run it.
The cyborg software should solve it for you.
Use this web link and scroll to the bottom where it says software.
Select your window operating system.
http://www.cyborggaming.com/download.htm

hanss
10th November 2011, 17:08
Thank you for the information.
I have a Saitek Pro flight yoke. Which Cyborg download do I use?

Thanks

Regards

Hanss

UK Support 4
10th November 2011, 17:22
Hi, on the link page just click your operating system. at the bottom of the page (software)

then click download

hanss
12th November 2011, 15:29
Hi,

Thank you. I have downloaded it, but when trying to install, I get the following message: "The installed version of the application could not be determined. The sutup will now terminate."
I also cannot remove the progam as I get the same message.

Please help me?

Thanks

Hanss

UK Support 4
14th November 2011, 10:18
Hi,
this sounds like you have not UN-installed the ST software or UN-installed it correctly.
Go to add and remover software, UN-install ST from here.
Also do this as well.
do try the following to see if it helps first:

Unplug the controller, click Start>Run, type regedit and click OK. In the Registry Editor browse to the following folders in order:

HKEY_LOCAL_MACHINE (HKEY_CURRENT_USER if using Vista)
SYSTEM
CurrentControlSet
Control
Media Properties
Private Properties
DirectInput

And delete any folder starting with VID_06A3.

Reinstall the downloaded ST.
Plug the controller back in, move it fully a couple of times and see if that has fixed it.

hanss
14th November 2011, 17:39
Sorry,

This does not work. I still get the same message.

Do you have another suggestion, please?

Regards

Hanss

UK Support 4
16th November 2011, 09:52
Hi, are you downloading the correct version for your operating system
i.e. windows7 64 and use the windows7 64 bit driver and software?
The error message you are getting sounds like it is the wrong version down loaded.

hanss
18th November 2011, 21:37
Hi,

I have checked again but I did use the correct download.
Do have other suggestions of what it might be?

Regards

Hanss

UK Support 4
21st November 2011, 10:55
Hi, try this, this is what one of our other customers did.
see if it does the trick.

error 32 in UpdateDriverForPlugAndPlayDevices: the process cannot access the file because it is being used by another process.

Go into Device Manager and open the Saitek Magic Bus category. Uninstall the Magic Keyboard first and then the Magic Mouse, then the Hot-key Device and then finally the Root Enumerator.

Now try installing the software.

To overcome this issue with the following steps:
1) Use WinRAR to extract the SST package to a folder of my choice.

2) In that folder, I located and installed the software_loc_9.msi. It's the English localized profiler installer -found it through trial and error.

3) In the same folder, I ran Set-up.exe and installed the Magic Bus Drivers.

(In short terms, I did what the SST installation package should have done in the first place...)

It doesn't matter if you already installed the magic bus drivers through standard installation. Just follow the steps as they are and you'll be fine. Tested it and it works like it should.

Also, watch out for the driver versions I mentioned above. The stick can surprisingly revert to an older driver, if you switch USB ports...

hanss
24th November 2011, 22:13
Hello,

I solved the problem. Thanks for your advise.
However problems never come alone.
I have a unreliable DIN cable which connects the yoke with the throttle quadrant. Could you give me the specification of the plug so that I can lengthen the cable by using a female and a male cable of the same sort?

thanks very much

Hanss

UK Support 4
28th November 2011, 10:29
Hi,
The plug to use is a standard PS2, 6 pin, pin to pin (the type use on PS2 keyboards). this will connect the same wires from the yoke to the quadrant.
I hope this helps.

hanss
28th November 2011, 22:20
I have ordered a plug of the kind.

Thank you for your advice

Regards

Hanss